Build an MQTT based RGB LED panel! // Project

Hello, I’m very interested in this project and I have ordered all the needed parts to do it. In case of using an Adafruit bonnet, I’ve seen that for 64x64 matrix panels you need to connect in the lower side of the bonnet a couple of points (8 or 16) with a solder blob, but I have not seen this on your instructions. Could you please confirm if this is needed or not?

Thanks a lot and best regards / Fernando

1 Like

Hey Mick how are you doing
hope the storm did not do to mutch damage to your house
quick quetion how did you manage to run the clock text and the background image in one go using the rpi-rgb-matrix library

and it it possible to run your code without docker
and if so how tried running and compiling it but no luck so far

1 Like

Essentially, I’m drawing each layer on top of each other. That is: start from the lower layer and draw up. So, no sprites or any fancy graphics primitives.

It is possible to run it without Docker. Once I get a bit of bandwidth I want to revisit this project and rewrite it in GoLang. This will reduce the amount of complexity and enable a single executable to run.
Of course you could still run it in Docker as well. Either way.

If you look at the Dockerfile on GitHub it has all the build method contained within a script. You’ll just have to be careful about paths.

Hi Mike, thanks for sharing this awesome little project!
However currently the installation of Docker on the pi0 is not working. Follow the instructions in this thread: to fix the install.

1 Like

Thanks mate! I’ll check it out.

Problem with config.txt. Where you edited config.txt in the section called “SD card changes”, this caused RPi3ModB+ to hang during boot. I’m using raspbian GNU/Linux 9 (stretch). The suggested modifications dtparam=audio=off and
dtoverlay=dwc2 caused the boot to hang. I’ll let you know more if the program doesn’t work without these changes.

1 Like

Hi Larry,
How did those changes go? Surprised it hung the Pi. They’re pretty common config options.

I finally got the display running on my Pi Zero W . I am using all the same part indicated in the project. The problem i am having is with the graphics. They are not displaying correctly on both of of the systems i built for my nephews.
Does anyone have a corrective action for this?


Ah, that would be a bug in the code.
I’ve been meaning to rewrite this in GoLang and have been looking at it this last week.
Hopefully I’ll have it finished by the end of next week.

Thanks Mick,
My Nephews are looking forward to getting this to work.

1 Like

I have the solution for you! look at this Adafruit page - Step 3 about 64x64 matrixes -

I had to blob signal E to GPIO Pin 8 like the picture shows and presto!!!

Good luck with your project!

1 Like

Thanks for the reply.
I will try it tonight.
Thanks Again!

1 Like

Mick, I am getting the same problem as Face_Death. Do you know where I might be able to find the updated code? Thank you for this project, I hope I can get it working!

1 Like

Did you ever get it to work for you? I am running into the same issues that you posted about.

1 Like

Yes, just soldered the contact indicated by Geroge_Lindner as indicated on board, Thanks Again! and the display came up correct. Just ran into other problems with the time displaying correctly. Have not had a chance to review this issue. Not a fan of MQTT, probably because i don’t fully understand the operation and control of it.


Sorry guys, I’ve been pretty busy of late and haven’t had a chance to update the code.
Hopefully I’ll get to it in the next couple of weeks.

Hi =) First thanks for sharing this very nice project.

I’m unfortunately inexperienced. how can I upload my own GIF picture? Can you please tell me how it works?

would it be possible to create a container yourself with the files from GitHub? Can’t I put my own GIF in the rgbmatrix folder and then build a container and install it via ssh?
what would be the procedure in this case?

A last question…
How can i setup the time that is shown on the Matrix. I was able to successfully set the time from the Raspberry itself. but the time shown (on the matrix) is one hour early.

Have a lot of thanks =)

Hi stetho,
I have the time issue as well. I don’t understand how to use docker. How did you start the container with the -v and -e options? Can you show the entire docker command line that you used to start the container?

docker run -v /etc/timezone:/etc/timezone -v /etc/localtime:/etc/localtime:ro
<everything else from the tutorial goes here>

Thanks stetho! It worked!